phpmyadmin 出现提示 “ 缺少 mcrypt 扩展。请检查 PHP 配置。 ”

php版本从5.x 切换到PHP7.x之后, phpmyadmin 出现提示 “ 缺少 mcrypt 扩展。请检查 PHP 配置。 ”

在windows下,使用的是phpstudy 环境

阅读 4.5k
3 个回答

因为你的php7没有安装扩展:
以php7.0为例:

sudo apt-get update
sudo apt-get install mcrypt php7.0-mcrypt
sudo apt-get upgrade

如果是apache的话
sudo service apache2 restart

然后检查是否安装成功:

php -m

查找mcrypt

搞定!

windows下,估计是php.ini里直接去掉;就OK了

编译的话是:

tar zxvf mcrypt-2.6.8.tar.gz //注意版本号
cd mcrypt-2.6.8
LD_LIBRARY_PATH=/usr/local/lib ./configure
make
make install

PHP编译增加 --with-mcrypt

phpstudy 中,不同php版本有不同的PHP目录文件,文件名称就能看出是哪个版本的。进入相应的版本PHP文件目录,打开php.ini 打开相应的扩展项,同时查看当前目录下extend扩展目录里有没有相应的扩展,没有就下载一个pecl.php.net中可以下载window版和linux版的

linux 下以上各位说的很清楚了

撰写回答
你尚未登录,登录后可以
  • 和开发者交流问题的细节
  • 关注并接收问题和回答的更新提醒
  • 参与内容的编辑和改进,让解决方法与时俱进
推荐问题
宣传栏