变量命名的问题:叫 btnAdd 还是 addBtn 呢?

SYLiu
  • 537

首先限定为:驼峰命名法。

虽然叫什么都可以,但是还是有个规范比较好。想听听大家的看法,或者推荐一下这方面的规范。
add是说明 button 功能的,如果再加一个描述 button 的词 small 呢?

btnAddSmall?
btnSmallAdd?
smallAddBtn?
addSmallBtn?
addBtnSmall?
smallBtnAdd?
...

回复
阅读 1.4k
11 个回答

一般来说变量应该是个名词,比如 btn。后面还可以加状语,比如 btnAdded,表按钮已经完成了添加动作。

但 btnAdd,给我的感觉就是,不知道这个按钮正处于什么时刻,对即将发生些什么,不是那么明确。

应该都可以,平时开发的时候我也是两种都会用。
第一种是把名词前置,不符合自然语言的表达习惯,但好处是有利于代码的整齐和代码提示。

第二种跟自然语言一致,但缺点正好是第一种的优点。

btnAdd/buttonAdd,类似有lblPrice,txtName,应该是来自C/C++习惯里面的uintId的把类型前置,名称后置的命名方法

passwordField
addBtn
喜欢后置

行为前置,比如 addBtn,状态后置,比如 btnAdded,个人习惯,不喜勿喷。

个人习惯问题吧。。一般来说addBtn这种用的人多点吧
一般来说前缀都是说明功能 不知道加small是干嘛
一定要加的话 我个人更倾向于smallAddBtn

addBtn
small 应该是方法的一个枚举类
如果是DDD直接去掉最后的名词

应该都可以,平时开发的时候我也是两种都会用。

都可以。。这个没有规定,只要遵循统一规则,让别人看得懂就可以。。。

wjiali6
  • 3
新手上路,请多包涵

可以使用谷歌的命名规则,对你当前问题,推荐使用addButton这种命令前置式。

过客
  • 1
新手上路,请多包涵

推荐使用下划线
Add_Button_ForReason_OfWho.
一般变量名称首字母还是小写的。

撰写回答
你尚未登录,登录后可以
  • 和开发者交流问题的细节
  • 关注并接收问题和回答的更新提醒
  • 参与内容的编辑和改进,让解决方法与时俱进
你知道吗?

宣传栏