vagrant up报错

xueyubingsen
  • 3
新手上路,请多包涵

vagrant up报错如下

C:/zjsw/HashiCorp/Vagrant/embedded/gems/2.2.4/gems/net-sftp-2.1.2/lib/net/sftp/response.rb:70:in `block in <class:Response>': undefined method `downcase' for nil:NilClass (NoMethodError)
        from C:/zjsw/HashiCorp/Vagrant/embedded/gems/2.2.4/gems/net-sftp-2.1.2/lib/net/sftp/response.rb:68:in `each'
        from C:/zjsw/HashiCorp/Vagrant/embedded/gems/2.2.4/gems/net-sftp-2.1.2/lib/net/sftp/response.rb:68:in `inject'
        from C:/zjsw/HashiCorp/Vagrant/embedded/gems/2.2.4/gems/net-sftp-2.1.2/lib/net/sftp/response.rb:68:in `<class:Response>'
        from C:/zjsw/HashiCorp/Vagrant/embedded/gems/2.2.4/gems/net-sftp-2.1.2/lib/net/sftp/response.rb:16:in `<module:SFTP>'
        from C:/zjsw/HashiCorp/Vagrant/embedded/gems/2.2.4/gems/net-sftp-2.1.2/lib/net/sftp/response.rb:3:in `<module:Net>'
        from C:/zjsw/HashiCorp/Vagrant/embedded/gems/2.2.4/gems/net-sftp-2.1.2/lib/net/sftp/response.rb:3:in `<top (required)>'
        from C:/zjsw/HashiCorp/Vagrant/embedded/mingw64/lib/ruby/2.4.0/rubygems/core_ext/kernel_require.rb:55:in `require'
        from C:/zjsw/HashiCorp/Vagrant/embedded/mingw64/lib/ruby/2.4.0/rubygems/core_ext/kernel_require.rb:55:in `require'
        from C:/zjsw/HashiCorp/Vagrant/embedded/gems/2.2.4/gems/net-sftp-2.1.2/lib/net/sftp/request.rb:2:in `<top (required)>'
        from C:/zjsw/HashiCorp/Vagrant/embedded/mingw64/lib/ruby/2.4.0/rubygems/core_ext/kernel_require.rb:55:in `require'
        from C:/zjsw/HashiCorp/Vagrant/embedded/mingw64/lib/ruby/2.4.0/rubygems/core_ext/kernel_require.rb:55:in `require'
        from C:/zjsw/HashiCorp/Vagrant/embedded/gems/2.2.4/gems/net-sftp-2.1.2/lib/net/sftp/session.rb:5:in `<top (required)>'
        from C:/zjsw/HashiCorp/Vagrant/embedded/mingw64/lib/ruby/2.4.0/rubygems/core_ext/kernel_require.rb:55:in `require'
        from C:/zjsw/HashiCorp/Vagrant/embedded/mingw64/lib/ruby/2.4.0/rubygems/core_ext/kernel_require.rb:55:in `require'
        from C:/zjsw/HashiCorp/Vagrant/embedded/gems/2.2.4/gems/net-sftp-2.1.2/lib/net/sftp.rb:2:in `<top (required)>'
        from C:/zjsw/HashiCorp/Vagrant/embedded/mingw64/lib/ruby/2.4.0/rubygems/core_ext/kernel_require.rb:55:in `require'
        from C:/zjsw/HashiCorp/Vagrant/embedded/mingw64/lib/ruby/2.4.0/rubygems/core_ext/kernel_require.rb:55:in `require'
        from C:/zjsw/HashiCorp/Vagrant/embedded/gems/2.2.4/gems/vagrant-2.2.4/plugins/communicators/ssh/communicator.rb:12:in `<top (required)>'
        from C:/zjsw/HashiCorp/Vagrant/embedded/mingw64/lib/ruby/2.4.0/rubygems/core_ext/kernel_require.rb:55:in `require'
        from C:/zjsw/HashiCorp/Vagrant/embedded/mingw64/lib/ruby/2.4.0/rubygems/core_ext/kernel_require.rb:55:in `require'
        from C:/zjsw/HashiCorp/Vagrant/embedded/gems/2.2.4/gems/vagrant-2.2.4/plugins/communicators/ssh/plugin.rb:14:in `block in <class:Plugin>'
        from C:/zjsw/HashiCorp/Vagrant/embedded/gems/2.2.4/gems/vagrant-2.2.4/lib/vagrant/registry.rb:27:in `get'
        from C:/zjsw/HashiCorp/Vagrant/embedded/gems/2.2.4/gems/vagrant-2.2.4/lib/vagrant/machine.rb:259:in `communicate'
        from C:/zjsw/HashiCorp/Vagrant/embedded/gems/2.2.4/gems/vagrant-2.2.4/lib/vagrant/action/builtin/wait_for_communicator.rb:16:in `block in call'

是否有遇到相同情况的朋友?

回复
阅读 1k
撰写回答
你尚未登录,登录后可以
  • 和开发者交流问题的细节
  • 关注并接收问题和回答的更新提醒
  • 参与内容的编辑和改进,让解决方法与时俱进
宣传栏