0

问题描述

之前安装的版本是3.3.1的,后来项升级下,就把3.3.1源码目录删除了,重新下载了4.4.12的,编译的时候报错

问题出现的环境背景及自己尝试过哪些方法

php7.2 centos7

相关代码

// 请把代码文本粘贴到下方(请勿用图片代替代码)
/bin/sh /swoole-4.4.12/libtool --mode=compile g++ -I. -I/swoole-4.4.12 -DPHP_ATOM_INC -I/swoole-4.4.12/include -I/swoole-4.4.12/main -I/swoole-4.4.12 -I/usr/local/php/include/php -I/usr/local/php/include/php/main -I/usr/local/php/include/php/TSRM -I/usr/local/php/include/php/Zend -I/usr/local/php/include/php/ext -I/usr/local/php/include/php/ext/date/lib -I/swoole-4.4.12 -I/swoole-4.4.12/include -I/swoole-4.4.12/thirdparty/hiredis -DHAVE_CONFIG_H -g -O2 -Wall -Wno-unused-function -Wno-deprecated -Wno-deprecated-declarations -std=c++11 -c /swoole-4.4.12/swoole_http_server_coro.cc -o swoole_http_server_coro.lo
g++ -I. -I/swoole-4.4.12 -DPHP_ATOM_INC -I/swoole-4.4.12/include -I/swoole-4.4.12/main -I/swoole-4.4.12 -I/usr/local/php/include/php -I/usr/local/php/include/php/main -I/usr/local/php/include/php/TSRM -I/usr/local/php/include/php/Zend -I/usr/local/php/include/php/ext -I/usr/local/php/include/php/ext/date/lib -I/swoole-4.4.12 -I/swoole-4.4.12/include -I/swoole-4.4.12/thirdparty/hiredis -DHAVE_CONFIG_H -g -O2 -Wall -Wno-unused-function -Wno-deprecated -Wno-deprecated-declarations -std=c++11 -c /swoole-4.4.12/swoole_http_server_coro.cc -fPIC -DPIC -o .libs/swoole_http_server_coro.o
g++: 编译器内部错误:已杀死(程序 cc1plus)
Please submit a full bug report,
with preprocessed source if appropriate.
See http://bugzilla.redhat.com/bu... for instructions.
make: * [swoole_http_server_coro.lo] 错误 1

你期待的结果是什么?实际看到的错误信息又是什么?

改何如解决

CZC123 34
11月20日提问
1 个回答
0

已采纳

额,重新启动了阿里云实例,然后就正常了。。。

撰写答案

推广链接