程序中包含XP不支持的API,但并没有使用,为何无法在XP下运行?

1528140
  • 312

VS2017编写的程序中包含了大量XP中不支持的API,但代码中对环境做了判断,如果是XP下,包含这些API的函数并不会运行。为何这样编写出来的程序在XP下会无法运行?错误提示都是类似“无法定位程序输入点XXX于XXX中”,明明这部分api在XP下都没有使用到。
请问有办法解决吗?(不想单独再为XP编译一个版本了...)
万分感谢。

回复
阅读 814
1 个回答

按运行环境编译单独的 dll,动态加载大概可以

撰写回答
你尚未登录,登录后可以
  • 和开发者交流问题的细节
  • 关注并接收问题和回答的更新提醒
  • 参与内容的编辑和改进,让解决方法与时俱进
宣传栏