关于mac10.15安装nvm以及Command Line Tools问题

chow
  • 757

这几天给新电脑装环境遇到几个问题,

  1. 首先安装有些环境时提示需要安装Command Line Tools,我在下载网站没找macOS为10.15的版本(也可能我没搜全),然后我安装的10.14版本,安装成功,但是brew会提示这个版本太低,导致通过brew安装别的环境也没成功。
  2. 安装nvm,我根据网上教程安装后,也修改那些文件了,然后再终端运行nvm后能看见版本,但是我新开一个终端就没了,同时安装的node也没了,经过几次尝试还是会出现这个问题,就是nvm和安装的node只在运行source那行命令的终端有效,其他都没效果

求教各位怎么解决,以及只做前端和node开发是否需要装xcode,感觉太大了,好多用不到

回复
阅读 973
2 个回答

建议安装上,主要是有一些 lib 和工具,在 npm install 的时候需要使用本地构建工具链来构建.如果不想折腾,就安装一下 xcode 就好

nvm和安装的node只在运行source那行命令的终端有效

node 路径加入 $PATH

你知道吗?

宣传栏