easyswoole无法启动

cauliflowor
  • 9

环境

  • PHP7.4.3
  • Swoole4.5.5
  • Ubuntu20.14
  • pcntl扩展已有

操作步骤

根据官方文档:

composer require easyswoole/easyswoole=3.x
php vendor/easyswoole/easyswoole/bin/easyswoole install

提示:

install success,enjoy!!!
dont forget run composer dump-autoload !!!

执行了composer dump-autoload后,再执行php easyswoole start出现:

#!/usr/bin/env sh

dir=$(cd "${0%[/\\]*}" > /dev/null; cd '../easyswoole/easyswoole/bin' && pwd)

if [ -d /proc/cygdrive ]; then
    case $(which php) in
        $(readlink -n /proc/cygdrive)/*)
            # We are in Cygwin using Windows php, so the path must be translated
            dir=$(cygpath -m "$dir");
            ;;
    esac
fi

"${dir}/easyswoole" "$@"

原封不动的输出了vendor/bin/easyswoole文件的内容,是怎么回事呢?

回复
阅读 1.9k
2 个回答

最新版本应该是
php easyswoole server start

东张西望
  • 2
新手上路,请多包涵
撰写回答
你尚未登录,登录后可以
  • 和开发者交流问题的细节
  • 关注并接收问题和回答的更新提醒
  • 参与内容的编辑和改进,让解决方法与时俱进
宣传栏