有没有更好的方式改写下面的||判断呢?

有这么一个判断,可能会有更多值

if (code === 10 || code === 15 || code === 25){
....
}

我试着这么写:

if (code === 10 || 15 ||  25){
....
}

不起作用,改怎么写才能美化些呢?

阅读 2.1k
3 个回答

列了几种供你参考:

if ([10, 25, 35, 50].includes(code))
if ([10, 25, 35, 50].some(val => val === code))
if ([10, 25, 35, 50].indexOf(code) !== -1)

image.png

if ([10, 15, 25].includes(code))

P.S. 以可读性和可维护性为第一要务,代码单纯地缩短一点并没有什么卵用。

const arr = [10,15,20,25]
if(arr.includes(code)){}
或者
if(arr.indexOf(code)!==-1){}
撰写回答
你尚未登录,登录后可以
  • 和开发者交流问题的细节
  • 关注并接收问题和回答的更新提醒
  • 参与内容的编辑和改进,让解决方法与时俱进
推荐问题