买了m1的mac之后无法使用vagrant来开发了怎么办?

ponponon
  • 315

x86 时代可以使用 vagrant + vbox 的组合,统一大家之间的开发环境。但是现在 mac 变成 arm 之后

  • vbox 不提供 arm 支持
  • mac 换成 vmware+vagrant 之后,vmware 下的 box 文件是没法在 vbox 上使用的吧,(即 box 文件有软件依赖性,如果跨软件使用)
  • box 文件不仅仅有软件依赖性,还有 cpu体系架构 依赖性,都换成 vmware+vagrantm1 的 mac 和无法和 x86 的 mac 之间用传输 box 文件的方式协同工作吧

vbox/vmware + vagrant 的组合是不是已经死亡了

回复
阅读 1k
2 个回答

只能等,ARM 虚拟机现在还不成熟;要么就别买 M1 Mac;要么改成 Docker 的方式。

P.S. VirtualBox 已经明确表示没有支持 ARM 的计划,所以你只能等 VMWare 和 Parallels。

撰写回答
你尚未登录,登录后可以
  • 和开发者交流问题的细节
  • 关注并接收问题和回答的更新提醒
  • 参与内容的编辑和改进,让解决方法与时俱进
宣传栏