求解:vite打包element-plus@1.0.2-beta.71这个版本的时候报错,报错信息如下图,这该怎么解决?

soulninu
  • 73

image.png
vitescss配置:

// css预设配置
    css: {
      preprocessorOptions: {
        less: {
          javascriptEnabled: true
        },
        sass: {
          javascriptEnabled: true
        },
        scss: {
          // example : additionalData: `@import "./src/design/styles/variables";`
          // dont need include file extend .scss
          // additionalData: `@import "./src/assets/css/global.scss";`
          additionalData: `@use "@/assets/css/global.scss" as *;`,
        }

      }
    },
回复
阅读 797
1 个回答

element-plus新版中的math.div在旧版sass中不支持导致的报错。
我将"sass": "^1.32.8",更新到了"sass": "^1.44.0",就可以正常打包了。

撰写回答
你尚未登录,登录后可以
  • 和开发者交流问题的细节
  • 关注并接收问题和回答的更新提醒
  • 参与内容的编辑和改进,让解决方法与时俱进
宣传栏