composer安装rabitMQ扩展报错求助

通过以下指令安装PHP第三方扩展的时候报错了,命令如下:

composer require php-amqplib/php-amqplib

报错信息如下:

Problem 1
    - Root composer.json requires alibabacloud/darabonba-openapi ^2.1, found alibabacloud/darabonba-openapi[dev-master, 0.1.0, ..., 0.2.5] but it does not match the constraint.
  Problem 2
    - Root composer.json requires alibabacloud/dysmsapi-20170525 1.0.2 -> satisfiable by alibabacloud/dysmsapi-20170525[1.0.2].
    - alibabacloud/dysmsapi-20170525 1.0.2 requires alibabacloud/darabonba-openapi ^0.1.8 -> found alibabacloud/darabonba-openapi[0.1.8, 0.1.9] but it conflicts with your root composer.json require (^2.1).

You can also try re-running composer require with an explicit version constraint, e.g. "composer require php-amqplib/php-amqplib:*" to figure out if any version is installable, or "composer require php-amqplib/php-amqplib:^2.1" if you know which you need.

有知道如何处理的朋友麻烦帮忙解答一下,谢谢。

回复
阅读 852
1 个回答
撰写回答
你尚未登录,登录后可以
  • 和开发者交流问题的细节
  • 关注并接收问题和回答的更新提醒
  • 参与内容的编辑和改进,让解决方法与时俱进
宣传栏