windowns 7 安装scrapy ,头大了。一直提示这个openssl 没有这个东西?

windowns 7 安装scrapy ,头大了。一直提示这个openssl 没有这个东西

试了好多方法安装这个openssl 也没用。有知道的朋友吗? 谢谢。

CJROBY42~%09QK}3D$DZHCB.png

回复
阅读 572
1 个回答

在setting文件中配置
DOWNLOADER_CLIENT_TLS_METHOD

下面是可选的值:

'TLS': maps to OpenSSL’s TLS_method() (a.k.a SSLv23_method()), which allows protocol negotiation, starting from the highest supported by the platform; default, recommended

'TLSv1.0': this value forces HTTPS connections to use TLS version 1.0 ; set this if you want the behavior of Scrapy<1.1

'TLSv1.1': forces TLS version 1.1

'TLSv1.2': forces TLS version 1.2

'SSLv3': forces SSL version 3 (not recommended)

你配置成 TLSv1.2或者其他试试

https://doc.scrapy.org/en/lat...

撰写回答
你尚未登录,登录后可以
  • 和开发者交流问题的细节
  • 关注并接收问题和回答的更新提醒
  • 参与内容的编辑和改进,让解决方法与时俱进
推荐问题
宣传栏