CodeIgniter 与 PHP 版本的兼容性?

新手上路,请多包涵

我在 PHP 5.5 中使用 CodeIgniter 2.2.6,它工作正常。现在我想将 PHP 升级到版本 5.6.6 我的问题是,CodeIgniter 与 PHP 5.6.6 兼容吗?

我无法将 CodeIgniter 升级到新版本,因为我有很多基于版本 2.2.6 的模型。

原文由 jamal 发布,翻译遵循 CC BY-SA 4.0 许可协议

回复
阅读 97
1 个回答

Codeigniter 2.2x 与 PHP7.1+ 兼容。

你只需要记住:

  1. 模型/类等区分大小写,必须以大写字母开头
  2. 与应用程序文件夹中的文件名相同
  3. mysql 有问题(很老,现在没有使用驱动)所以你必须使用 mysqli 驱动(但它已经在 CI2 中实现,检查你是否已经没有使用它)
  4. 如果您有会话表,有时您将不得不截断该表,清除缓存并再次填充它。
  5. 如果遇到问题,请检查 third_party 文件夹中软件的兼容性 - CI 不对该问题负责。

在我的例子中,安装了最新版本的 bootstrap 和 jQuery 后一切正常。但是,我没有使用钩子、高级函数等。

注意,在大多数情况下,您可以使用 .htaccess 和 AddHandler 命令强制服务器使用旧的 php 版本:

 AddHandler application/x-httpd-php56 .php

这是 PHP7 之前的最后一个 PHP 版本。

最后但 同样重要的是——当然我不建议使用这个非常旧的 CI 版本,但是在我看来——在我的情况下——从 CI2x 迁移到 CI3 是没有意义的,在 2018 年最好等待CI4 然后迁移。

原文由 Vilq 发布,翻译遵循 CC BY-SA 3.0 许可协议

撰写回答
你尚未登录,登录后可以
  • 和开发者交流问题的细节
  • 关注并接收问题和回答的更新提醒
  • 参与内容的编辑和改进,让解决方法与时俱进
推荐问题
宣传栏