nuxt项目npm引入了一个vue3开发的包,打包时会报ERR_REQUIRE_ESM]: Must use import to load ES Module,该如何忽略这个包里的eslint?

nuxt项目npm引入了一个vue3开发的包,打包时会报ERR_REQUIRE_ESM]: Must use import to load ES Module,该如何忽略这个包里的eslint?

本地开发的nuxt项目,node版本是14.17,引入的npm包是别的项目组开发的,他们的node是16以上。
在打包npm run generate时,会报Error [ERR_REQUIRE_ESM]: Must use import to load ES Module。导致生成index.html文件失败。
通过查看node_modules里的引入npm包发现他们的package.json有引入eslint v8.16。这个报错是他们的eslint抛出导致的还是说是因为我们本地node版本太低导致的呢?

该如何解决

阅读 242
撰写回答
你尚未登录,登录后可以
  • 和开发者交流问题的细节
  • 关注并接收问题和回答的更新提醒
  • 参与内容的编辑和改进,让解决方法与时俱进
推荐问题
宣传栏