macos 10.8.3安装php5.4总是显示系统的5.3版本

vsvsvsvs
  • 851

操作是用homebrew进行安装。

php信息
可是到了和系统的apache结合的时候,不知道libphp5.so的文件。装载的是系统的libphp.so文件。
httpd.conf 配置信息装载文件
LoadModule php5_module libexec/apache2/libphp5.so
系统显示:
请输入图片描述
就是不知道homebrew安装的libphp5.so的文件安装。系统是无法找到的。
有没有详细的配置方案刚学,就是无法装载php5.4。

回复
阅读 5.6k
2 个回答
李惟
  • 2.1k
cp /usr/local/php5/lib/php.ini in /etc/php.ini
cp /usr/local/php5/bin/php in /usr/bin/php

# 如果你有安装phar #
cp /usr/local/php5/bin/phar in /usr/bin/phar
cp /usr/local/php5/bin/phar.phar in /usr/bin/phar.phar

cp /usr/local/php5/php in /usr/bin/php
cp /usr/local/php5/php-config in /usr/bin/php-config
cp /usr/local/php5/bin/phpize in /usr/bin/phpize

备注

  1. /usr/local/php5 替换成你安装PHP5.4的目录
  2. 以上不是所有文件都要拷贝过去,请根据你的安装情况文件映射
  3. 部分文件可能路径写的不对,请根据自己安装情况,在安装PHP的目录中查找

当初用homebrew 安装php时候shell脚本是

brew install php54 --with-debug --with-fpm --with-intl --with-tidy 

似乎--with-fpm安装的时候不会编译libphp5.so文件。

brew install php54 --with-debug --with-homebrew-openssl --with-imap --with-intl  --with-tidy

这样重新安装就可以加载文件了。
LoadModule php5_module /usr/local/opt/php54/libexec/apache2/libphp5.so

撰写回答
你尚未登录,登录后可以
  • 和开发者交流问题的细节
  • 关注并接收问题和回答的更新提醒
  • 参与内容的编辑和改进,让解决方法与时俱进
宣传栏