GD Library extension not available with this PHP installation.

曾经
  • 119

laravel 调用intervention,
php配置显示gd库已经安装

php -i | grep -i gd

/etc/php5/cli/conf.d/20-gd.ini,
gd
GD Support => enabled
GD Version => 2.1.1-dev
gd.jpeg_ignore_warning => 0 => 0

回复
阅读 3.6k
2 个回答

命令行执行 php 时调用的 php.ini 和 apache/ngix 调用php模块时使用的php.ini通常不是同一个文件,你可以新建一个 info.php 调用 phpinfo() 然后在浏览器中打开,看看里面有没有GD库。

debian 执行sudo apt-get install php5-gd
撰写回答
你尚未登录,登录后可以
  • 和开发者交流问题的细节
  • 关注并接收问题和回答的更新提醒
  • 参与内容的编辑和改进,让解决方法与时俱进
宣传栏