Echarts引入的wordcloud.min.js和自己下载的echarts.min.js有冲突?

cchh13
  • 3
新手上路,请多包涵

引用自己下载的echarts.min.js(饼图 雷达图 仪表盘)以后,wordcloud就不显示了,请问怎么解决?
引用之前:

引用之后:

f12控制台:

回复
阅读 962
1 个回答

从报错信息来看你使用的是经过二次封装的 echarts-wordcloud 而不是 wordcolud。因此此类错误最有可能是由于版本不匹配或者是插件引入顺序导致的问题。

建议检查版本,并按官方示例的顺序引入插件脚本:

<script src="echarts.min.js"></script>
<script src="echarts-wordcloud.min.js"></script>
注意:echarts-wordcloud 插件在 2.0 版本时才支持 echarts >= 5.0。
撰写回答
你尚未登录,登录后可以
  • 和开发者交流问题的细节
  • 关注并接收问题和回答的更新提醒
  • 参与内容的编辑和改进,让解决方法与时俱进
你知道吗?

宣传栏