低版本 chrome 如何解决 JS 版本兼容问题?

linong
  • 19.5k

昨天用户反馈 bug,qq 的三方登录不能扫码了。其实这个问题之前也检查过一些,有用户 dns 解析不到的,有写死 hosts 都不通的,但是这次不一样了,我也不能扫码了

这就很恐怖了,如果出事故这都年底了,我的年终奖怎么办?火速打开了我的最新版 chrome 试了一下别人家的,凉了,网页版可以扫码。

无奈直接调试页面了,但是调试的时候我发现了问题,居然是他们写的代码出了问题。就下图被注销的地方(昨天的bug,今天就解决了,不知道腾讯老哥的年终奖有没有受到影响)。他们这个 bug 只在老版本会有问题,新版本是可以正常使用的。

那么问题来了

  1. 在使用老版本的时候,如何去让项目避免这些问题?(我们是 pc 客户端)
  2. 不考虑大批量解决,只针对这一个问题,如果腾讯不改,那么我们如何修复?

image.png

回复
阅读 604
撰写回答
你尚未登录,登录后可以
  • 和开发者交流问题的细节
  • 关注并接收问题和回答的更新提醒
  • 参与内容的编辑和改进,让解决方法与时俱进
你知道吗?

宣传栏